本题要求你帮助某网站的用户注册模块写一个密码合法性检查的小功能。该网站要求用户设置的密码必须由不少于6个字符组成,并且只能有英文字母、数字和小数点 .,还必须既有字母也有数字。

输入格式:

输入第一行给出一个正整数 N(≤ 100),随后 N 行,每行给出一个用户设置的密码,为不超过 80 个字符的非空字符串,以回车结束。

输出格式:

对每个用户的密码,在一行中输出系统反馈信息,分以下5种:

如果密码合法,输出Your password is wan mei.;
如果密码太短,不论合法与否,都输出Your password is tai duan le.;
如果密码长度合法,但存在不合法字符,则输出Your password is tai luan le.;
如果密码长度合法,但只有字母没有数字,则输出Your password needs shu zi.;
如果密码长度合法,但只有数字没有字母,则输出Your password needs zi mu.。

输入样例:

5
123s
zheshi.wodepw
1234.5678
WanMei23333
pass*word.6

输出样例:

Your password is tai duan le.
Your password needs shu zi.
Your password needs zi mu.
Your password is wan mei.
Your password is tai luan le.

特别注意点:

坑爹的第三验证点,不能直接使用cin,因为会有空格,而且这里需要注意要用getline接收一行字符。在接收完n后要getchar()读取一下换行符才能用getline,否则换行符会被读进getline中

代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cctype>
using namespace std;
int main(){
int n;
cin>>n;
getchar();
for(int i=0;i<n;i++){
// cin>>s;
string s;
getline(cin,s);
//第一种不合法情况
if(s.length()<6)
cout<<"Your password is tai duan le."<<endl;
else{
int acount=0,ncount=0,flag =0;
for(int j=0;j<s.length();j++){
if(!isalnum(s[j]) && s[j]!='.') {
flag=1;
}else{
if(isalpha(s[j]))
acount=1;
else if(isdigit(s[j]))
ncount=1;
}
}
//第二种不合法情况
if(flag==1)
cout<<"Your password is tai luan le."<<endl;
//第三种不合法情况
else if(ncount==0)
cout<<"Your password needs shu zi."<<endl;
//第四种不合法情况
else if(acount==0)
cout<<"Your password needs zi mu."<<endl;
//完美的情况
else
cout<<"Your password is wan mei."<<endl;
}

}
return 0;
}