请编写程序,找出一段给定文字中出现最频繁的那个英文字母。

输入格式:

输入在一行中给出一个长度不超过 1000 的字符串。字符串由 ASCII 码表中任意可见字符及空格组成,至少包含 1 个英文字母,以回车结束(回车不算在内)。

输出格式:

在一行中输出出现频率最高的那个英文字母及其出现次数,其间以空格分隔。如果有并列,则输出按字母序最小的那个字母。统计时不区分大小写,输出小写字母。

输入样例:

This is a simple TEST. There ARE numbers and other symbols 1&2&3………..

输出样例:

e 7

代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
#include <cctype>
using namespace std;
int main(){
string s;
int a[26]={0};
getline(cin,s);//可以接收空格
for(int i=0;i<s.length();i++){
s[i]=tolower(s[i]);//全部转成小写
if(islower(s[i])) //排除非字母
a[s[i]-'a']++; //将字母转成数字
}
int max=0,n=0;
for(int i=0;i<26;i++){
if(a[i]>max){
max=a[i];
n=i;
}
}
char c = n+'a';
cout<<c<<" "<<max;
return 0;
}