旧键盘上坏了几个键,于是在敲一段文字的时候,对应的字符就不会出现。现在给出应该输入的一段文字、以及实际被输入的文字,请你列出肯定坏掉的那些键。

输入格式:

输入在 2 行中分别给出应该输入的文字、以及实际被输入的文字。每段文字是不超过 80 个字符的串,由字母 A-Z(包括大、小写)、数字 0-9、以及下划线 _(代表空格)组成。题目保证 2 个字符串均非空。

输出格式:

按照发现顺序,在一行中输出坏掉的键。其中英文字母只输出大写,每个坏键只输出一次。题目保证至少有 1 个坏键。

输入样例:

7_This_is_a_test
_hs_s_a_es

输出样例:

7TI

代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
//空格也需要进行判断 
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cctype>
#include <cstring>
using namespace std;
int main(){
string s1,s2,result;
bool HashTable[128]={false};
cin>>s1>>s2;
for(int i=0;i<s1.length();i++){
char c1,c2;
int j;
for(j=0;j<s2.length();j++){
c1=toupper(s1[i]);//都换成大写
c2=toupper(s2[j]);
//下面是判断
if(c1==c2) break;
}
if(c1!=c2&&HashTable[c1]==false){
result +=c1;
HashTable[c1]=true;
}
}
cout<<result;
return 0;
}
}