读入 n(>0)名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。

输入格式:

每个测试输入包含 1 个测试用例,格式为

第 1 行:正整数 n
第 2 行:第 1 个学生的姓名 学号 成绩
第 3 行:第 2 个学生的姓名 学号 成绩
… … …
第 n+1 行:第 n 个学生的姓名 学号 成绩
其中姓名和学号均为不超过 10 个字符的字符串,成绩为 0 到 100 之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。

输出格式:

对每个测试用例输出 2 行,第 1 行是成绩最高学生的姓名和学号,第 2 行是成绩最低学生的姓名和学号,字符串间有 1 空格。

输入样例:

3
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95

输出样例:

Mike CS991301
Joe Math990112

代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
#include <cstdio>
#include <iostream>
#include <algorithm>
using namespace std;
struct student{
string name,stuno;
int score;
}stu[10010];
int main(){
int n,maxs=0,mins=110;
cin>>n;
for(int i=0;i<n;i++){
cin>>stu[i].name>>stu[i].stuno>>stu[i].score;
if(stu[i].score>maxs)
maxs=stu[i].score;
if(stu[i].score<mins)
mins=stu[i].score;
}
for(int i=0;i<n;i++){
if(stu[i].score==maxs)
cout<<stu[i].name<<" "<<stu[i].stuno;
}
cout<<endl;
for(int i=0;i<n;i++){
if(stu[i].score==mins)
cout<<stu[i].name<<" "<<stu[i].stuno;
}
return 0;
}
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
import java.util.*;

public class Main {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int n = sc.nextInt();
sc.nextLine();
List<Stu> list = new ArrayList<>();
for(int i =0;i<n;i++){
String[] input = sc.nextLine().split(" ");
Stu stu = new Stu(input[0],input[1],Integer.parseInt(input[2]));
list.add(stu);
}
//排序
Collections.sort(list);
//输出最好的
System.out.println(list.get(n-1).tostring());
//输出最差的
System.out.println(list.get(0).tostring());
}
}
class Stu implements Comparable<Stu>{
String name;
String Sno;
int score;

public Stu(String name, String sno, int score) {
this.name = name;
this.Sno = sno;
this.score = score;
}

@Override
public int compareTo(Stu o) {
return this.score-o.score;
}
String tostring(){
return (this.name+" "+this.Sno);
}
}