Given three integers A, B and C in [ −2​63,2​63 ], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

题目翻译

给三个再范围内的整数A,B,C,你应该判断A+B是否大于C

输入格式:

输入的第一行给出一个正整数测试案例,T(≤10).后面紧接着为T个测试案例,每个案例为单独一行包含A,B,C,中间用空格分隔。

输入格式:

对于每个测试案例,如果判断成立则输出true,判断不对就为false。

代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
int main(){
int n;
cin>>n;
for(int i=0;i<n;i++){
long long a,b,c,d;
scanf("%lld %lld %lld",&a,&b,&c);
d=a+b;
if(a>0 && b>0 && d<0)
printf("Case #%d: true\n",i+1);
else if(a<0 && b<0 && d>=0)
printf("Case #%d: false\n",i+1);
else if(d>c)
printf("Case #%d: true\n",i+1);
else
printf("Case #%d: false\n",i+1);
}
return 0;
}