Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid “inside jobs” where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, …, S13,
H1, H2, …, H13, s
C1, C2, …, C13,
D1, D2, …, D13,
J1, J2
where “S” stands for “Spade”, “H” for “Heart”, “C” for “Club”, “D” for “Diamond”, and “J” for “Joker”. A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

题目翻译:

洗牌是玩牌中将牌随机打乱的过程,因为标准的洗牌技术看起来很弱,而且为了避免洗牌员工和赌徒“内部操作”进行不充分的洗牌,很多赌场开始使用自动洗牌机,你的工作就是模拟一个洗牌机器。

机器根据一个给定的随机顺序进行洗牌,并重复给定的次数,假设初始状态如下:
S1, S2, …, S13,
H1, H2, …, H13,
C1, C2, …, C13,
D1, D2, …, D13,
J1, J2
“S”代表黑桃,“H”代表红心,“C”代表梅花,“D”代表方块,“J”代表大王,给定的顺序是在[1,54]之间的不同整数排列,如果在第i个位置的数字是j,这意味着需要将卡片从i位置移动到j位置,例如:假如我们只有五个卡片:S3,H5,C1,D13和J2.给定一个洗牌顺序{4,2,5,3,1},这个结果就将会变成:J2,H5,D13,S3,C1.如果我们再次重复洗牌,这个结果将会是:C1,H5,S3,J2,D13.

输入格式

每个输入文件包含一个测试样例。对于每一个测试样例,第一行包含一个确切整数K(≤20),代表着重复次数,下一行包含一个给定的顺序,所有数字将在一行中以空格分隔。

输出格式

对于每一个测试案例,将洗牌结果打印在一行上,所有牌以空格分隔,且在末尾不能包含多余空格

代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
#include <cstdio>
#include <iostream>
#include <algorithm>
using namespace std;
string c="SHCDJ";
int main(){
int k;
cin>>k;
int start[55],end[55],num[55];//0位置不使用 ,所以用55
for(int i=1;i<55;i++){
cin>>num[i];
end[i]=i; //先用数字表示
}
for(int j=0;j<k;j++){//循环次数
for(int i=1;i<55;i++){
start[i]=end[i];
}
for(int k=1;k<55;k++){
end[num[k]]=start[k];
}
}
for(int i=1;i<55;i++){
end[i]=end[i]-1;
cout<<c[end[i]/13];
cout<<end[i]%13+1;
if(i!=54) cout<<" ";
}
return 0;
}